FreeBSD 7.2: Apache httpready filter – Failed to enable the ‘httpready’ Accept Filter

Setelah install apache22 webserver di FreeBSD 7.2 di VMware. Muncul tulisan Failed to enable the ‘httpready’ Accept Filter pada saat menjalankan apachenya.
Ternyata ini muncul karena modul accf_http (accept filter http) belum diload oleh kernel freebsd. Jadi ya harus di load secara manual. ada 2 cara untuk meload modul ini
1. dengan menggunakan command

 kldload accf_filter 

2. menambahkan accf_http_load=”YES” pada file /boot/loader.conf

accf_http ditempatkan pada socket untuk menyetujui menerima request HTTP. Digunakan untuk mencegah aplikasi menerima koneksi sampai head HTTP penuh atau GET request sudah diterima kernel. Ini berfungsi untuk mengurangi kerja CPU.
link

Repair Flasdisk

Pada suatu hari yang cerah dan tidak berawan saya pernah dimintai tolong teman tentang masalah pada flasdisknya. Berikut penyakit flasdisk yang di alami :
1. flasdisk masih terdetect oleh windows
2. saat flasdisk mau dibuka muncul notifikasi untuk dilakukan format ulang tetapi saat di format flasdisk tidak bisa di format
3. saat di check pada properties file system pada flasdisk = unknown dan besar kapasitas flasdisk 0 byte.

Pada saat itu saya sempat googling dan memamakai beberapa tools untu recovery flasdisk tapi masih gagal . kemuadian saya bawa aja flasdisk siapa tahu nantinya ketemu obat untuk ngobatinnya. Dan setelah 1 jam, 2 jam, 3 jam, dan seterusnya ternyata masih belum bisa juga.

Tapi tanpa disengaja saya menemukan artikel seperti masalah yang diatas. Memang betul pepatah “kalau sudah jodoh memang tidak akan kemana2”..hehehe..
CUkup sudah basa-basinya kita langsung aja ke triknya :

1. Download USB Viewer untuk mengetahui ID Vendor (VID) dan ID Product (PID)
Setiap produk dan merk flasdisk mempunyai VID dan PID yang unik membedakan dengan yang lainnya.

2. Setelah di ketahui VID dan PID flasdisk kemudian langsung menuju ke sini http://flashboot.ru/iflash.html

3. Berhubung web ini kalau ndak salah rusia bahasanya mungkin kaya aksara jawa. Kalau mau artinya tinggal pakai google translate. Masukkan VID dan PID dari flasdisk klik OK.
4. Akan muncul banyak merk flasdisk dan besarnya kapasitas. Pilih sesuai dengan merk dan kapasitas flasdisk masing2. bagian sebelah kanan ada toolnya kalau belum ada link downloadnya search aja di google.

5. Setelah download instal aplikasinya. Sebelum mulai aplikasi flashnya jangan lupa masukin flasdisk yg bermasalahnya. aplikasi akan otomatis mendeteksi kemudian tinggal klik start. tergantung dengan aplikasinya. pokoknya dicoba-coba aja sampai bisa intinya dari tools yg dipakai ini adalah menformat ulang flasdisk seperti semula.

6. Untuk flasdisk yang saya coba adalah flasdisk Kingston G2 2 GB. untuk aplikasinya bisa di download disini atau langsung cari seperti cara diatas sesuai VID dan PID flasdisk anda. aplikasi ini juga bisa digunakan untuk Kingston G2 dari 64 MB sampai 4 GB.

Semoga bermanfaat untuk yang mengalami masalah yang sama dengan saya. Keep Posting..!!

Cara mudah cari crack, patch, serial number di google

Iseng-iseng masuk ke salah satu forum dan akhirnya membaca bagaimana untuk cari crack, patch, serial number software windows di mbah google. Kemudian saya coba and maybe it’s work. Kenapa saya bilang maybe karena tidak semua dapat kita cari. Tapi tidak ada salahnya untuk mencoba. 😀

Key untuk mencarinya adalah dengan menambahkan kode ‘94FBR‘ (tanpa tada kutip) di belakang nama softwarenya. misalkan Nero Express 94FBR.
Yang namanya crack, patch, serial number tidak selamanya link yg ditampilkan itu benar bisa aja itu berupa virus ataupun malware. Oleh karena itu jangan lupa hidupkan antivirus dan antimalwarenya.
Ini saya sarankan hanya untuk mencari crack yang digunakan secara pribadi dan tidak untuk mencari keuntungan dan untuk belajar saja. Tetap beli software yang asli untuk penggunaan yang lebih profesional..:D

Mencari driver Komputer tanpa software

Assalamualaikum warohmatullahhi wabarokatuh. Pertama-tama mari kita panjatkan puji dan syukur kehadirat Allah SWT serta salam dan salawat selalu kita curahkan untuk junjungan kita nabi besar Muhammad saw. Sebelumnya alhamdulilah masih diberi kesehatan untuk nulis di blog ini lagi. Berhubung tips berikut sangat cepat dan mudah dilakukan makanya dikasih pembukaan dulu itung-itung pengingat kepada Allah yang Maha Pengasih lagi Maha Penyanyang..

Di hari yang cerah ini saya ingin menulis kembali dari artikel tips yang saya baca di forum indowebster yg mungkin berguna bagi saya dan yang membacanya..heheh

Berikut adalah tips untuk mencari driver dari komputer kita tanpa software alias manual dengan cara yang lebih cepat dan insyAllah akurat..:D
1. Cek driver perangkat komputer yang belum terinstall di device manager. biasanya untuk perangkat yang belum terinstal ditandai dengan tanda tanya warna kuning.
untuk yang belum tahu letak device manager klik kanan My Computer>>Properties. Pilih di Tabs Hardware>>Device Manager. atau silakan cari lewat control panel saja..

2. kemudian perhatikan di Other device terdapat tanda tanya kuning. jadi perangkat tersebut belum diinstall.

3 Klik kanan device yang belum terinstal drivernya kemudian pilih Properties.

4. Pilih Tabs Details. disitu akan terlihat instance ID dari perangkat yang dipilih. Dicopy saja ID perangkat tersebut dengan CTTL+C.

5. kemudian buka browser dan masuk ke alamat website berikut
http://devid.info/
6. Pastekan ID perangkat tadi dan klik search

7. kemudian dibawah akan muncul link yang terkait. dan silakan download driver sesuai dengan kebutuhan masing2..
8. Setelah selesai download jangan lupa untuk berdoa saat installnya..hehehe

Cukup sekian yang dapat saya sampaikan mohon maaf kalau ada kata-kata yang kurang berkenan. Semoga bermanfaat..

sumber : indowebster

Download ebook di Scribd

Kemarin saya cari artikel untuk bahan pekerjaannya saya, setelah googling salah satu artikel yang saya dapat ada di http://www.scribd.com. berhubungun koneksinya terbilang tidak begitu cepat jadi saya putuskan untuk langsung mendowload artikel tersebut. saya Klik tombol download…eh ternyata tidak langsung terdownload scribd minta artikel dari kita (mungkin bisa diistilahkan dengan barter) jadi untuk mengunduh artikel ini saya harus upload dulu terserah tidak dibatasi tentang apa. Tapi kalau kita sedang buru-buru akan sangant merepotkannya hal ini apalagi dengan koneksi yang lambat.
Kemudian saya cari gmana cara download di scribd eh dapat juga di forum indowebster. Terima kasih bwat indowebster..:kiss…:D
Kurang lebih untuk download di scribd berikut caranya :

1. Kalau mau download ebook nya bisa di buka di
http://www.scribd.com/mobile

2. kalau mau langsung download dari versi asli nya tinggal masukkan nilai angka yang ada di url nya ke
http://www.scribd.com/mobile/documents/xxxxxxxxx
contoh:
kita mo download ebook dengan judul “Cara-Menghitung-Rab-Rumah”

pada link berikut :
http://www.scribd.com/doc/31467450/Cara-Menghitung-Rab-Rumah

maka untuk mendownlod bisa kita buka link yang ini
http://www.scribd.com/mobile/documents/31467450/

Sumber

Mengatur Route di FreeBSD

A. Route command untuk mengubah tabel routing di freebsd secara manual biasanya terdapat enam perintah :
=> add : Add a route.

=> flush :Remove all routes.

=> delete : Delete a specific route.

=> change : Change aspects of a route (such as its gateway).

=> get : Lookup and display the route for a destination.

=> monitor : Continuously report any changes to the routing information base, routing lookup misses, or suspected network partitionings.

Memperbesar Partisi C di windows

Biasanya partisi C: di windows digunakan untuk install operating system dan aplikasi-aplikasi. Seiring dengan aplikasi yang diinstal bertambah banyak mengakibatkan spase di C semakin kecil. Misalkan kita install windows XP minimal sisa partisi di C adalah sebesar 200 MB dan jika kurang dari itu akan muncul peringatan low space in C. ini bisa berakibat kinerja bisa menurun. Mungkin lebih baiknya untuk sisanya saya sarankan sisa di partisi C minimal 1 GB.

Tapi misalkan kita sudah terlanjur memberi partisi C tidak terlalu besar dan saat ini space harddisknya tinggal sedikit kita dapat memperbesar partisi di C tersebut. Tapi alangkah baiknya kita melakukan backup data penting terlebih dahulu agar anda tidak menyesal jika nantinya saat partisi terjadi hal yang tidak diinginkan. Karena untuk biaya pemulihan / backup harddisk bisa saja lebih mahal dari harddisik yang anda punya sekarang.. Jadi jangan lupa untuk membackup dulu data penting.. Don’t Forget.!!!!!

Selanjutnya langsung aja ini saya tuliskan pengalaman saya memperbesar partisi C hasil dari tanya mbah google dan coba-coba di komputer orang..hahaha…Tapi alhamdulilah berhasil….

1. Saya menggunakan software partisi Easus Partition Master Home Edition. ini merupakan tool yang lumayan powerfull untuk digunakan selain itu software ini juga gratistististis…
Aplikasi ini bisa didownload di link berikut atau kita bisa mencarinya sendiri tentunya dengan bantuan mbah GooGle

Link Download

2. setelah didownload tampilannya kurang lebih sebagai berikut
Photobucket

Blokir Situs dengan Mikrotik

Kemarin saya dapat tugas untuk melakukan blokir terhadap situs. Tapi blok situs tersebuh harus berdasarkan waktu. jadi hanya waktu-waktu tertentu saja untuk dilakukan pemblokiran.
Biasanya ini mungkin digunakan untuk memblokir pada jam-jam kerja. Setelah searching dengan bantuan mbah google akhirnya nemu juga artikelnya dan saya coba dan alhamdulilah berhasil. Untuk kasus kali ini akan dilakukan pemblokiran situs facebook karena situs jejaring yang satu ini sangat sering sekali diakses. berikut langkah-langkahnya :

1. Membuat firewall filter untuk memblokir content facebook yang menggunakan port http/80.

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol tcp dst port=80 content="facebook" action=drop comment="blokir Facebook"

2. membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat. ada 3 script yang digunakan yaitu untuk mengaktifkan firewall, mendisable firewall dan disable firewall di hari libur dan enable di di hari kerja
a. script untuk mengaktifkan firewall

/system script add name="fb-deny" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=no}

b. script untuk mendisable firewall

/system script add name="fb-allow" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=yes}

c. script untuk disable firewall di hari libur dan enable di hari kerja

/system script add name="fb-holiday" policy=write,read,policy,test,sniff source={:if ([/system scheduler get [/system scheduler find on-event="fb-deny"] disabled] = true) do [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=no] else [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=yes]}

3. Membuat schedule untuk menentukan kapan firewall diaktifkan atau di nonaktifkan. untuk schedulernya bisa seperti berikut :
a. Schedule untuk mengaktifkan firewall pada jam kerja (09.00) :

/system scheduler add name="fb-09:00" start-date=jan/01/1970 start-time=09:00:00 interval=1d on-event="fb-deny"

b. Schedule untuk disable pada jam istriahat (12:00)

/system scheduler add name="fb-12:00" start-date=jan/01/1970 start-time=12:00:00 interval=1d on-event="fb-allow"

c. Schedule untuk mengaktifkan pada jam kerja (13.00)

/system scheduler add name="fb-13:00" start-date=jan/01/1970 start-time=13:00:00 interval=1d on-event="fb-deny"

d. schedule untuk disable pada jam pulang kantor ( > 18:00)

/system scheduler add name="fb-18:00" start-date=jan/01/1970 start-time=18:00:00 interval=1d on-event="fb-allow"

e. schedule untuk disable firewall di hari libur (Sabtu dan Minggu)

/system scheduler add name="fb-sabtu-minggu" start-date=aug/01/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler adalah Hari Sabtu. Dan parameter “interval” diberi nilai 7d.

f. schedule untuk mengaktifkan kembali di hari kerja (Senin)

/system scheduler add name="fb-senin" start-date=aug/03/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler adalah Hari Sabtu. Dan parameter “interval” diberi nilai 7d.

sumber : http://lulukn.abatasa.com

berikut saya sertakan konfigurasi dengan menggunakan winbox : untuk source bisa didownload di alamat dibawah ini

BLOK SITUS DENGAN WINBOX MIKROTIK

Removal WGA for windows XP

Ini merupakan tools yang digunakan untuk Menghilangkan Pesan “Ask for Genuine Microsoft Software”. ini muncul karena windows xp dikenali sebagai windows bajakan saat melakukan auto update windows.
Removal WGA dapat diunduh di link berikut :

REMOVAL WGA

Mempercepat Koneksi Internet dengan Squid di Windows

Squid merupakan salah satu tools proxy server yang sering digunakan untuk mempercepat koneksi internet yang lamban. Kenapa dengan squid bisa mempercepat koneksi internet karena salah satu keandalan yang bisa digunakan dengan squid adalah dengan menyimpan cache dari website yang telah kita buka di mesin server kita sendiri. Ini sangat berguna untuk alamat website yang sering kita akses. Setidaknya ini akan sangat berguna untuk siapa saja yang koneksi internetnya belum cepat.

Mungkin kita sering dengar penggunaan Squid di operating system linux ataupun turunannya. Untuk kesempatan kali ini saya ingin menulis install squid di windows. untuk yang saya pakai saya menggunakan windows 7 ultimate.

1. Download squid di SINI. Download untuk versi windows.
2. Ekstrak hasil download dan pindahkan ke direktori C:\
3. Buka lewat windows explorer dan masuk ke folder C:\squid\etc\
4. Anda akan melihat beberapa file yaitu cachemgr.conf.default,mime.conf.default,squid.conf.default,squid_radius_auth.conf.default
5. Rename file-file tersebut dengan menghilangkan .defaultnya. Mungkin ada baiknya file-file tersebut dibackup dulu biar misal ada kesalahan dalam konfigurasi kita bisa mengembalikan ke awal lagi.

6. Setelah sudah direname buka file squid.conf dengan editor kesayangan masing-masing boleh notepad , notepad++, atau editor yang lain.

7. Squid.conf merupakan file konfigurasi squid yang mana isi dari file inilah yang digunakan sebagai acuan jalannya squid proxy nantinya.

8. Dalam file squid.conf anda akan menjumpai beberapa parameter dan penjelesan dari masing-masing parameter. dibawah ini beberapa parameter yang akan diedit :
a. TAG: http_port
Port ini akan digunakan oleh squid. Port defaultnya adalah 3128. tapi kita bisa ubah sesuai keinginan. Kamu masukin http_port 3128 di bawah tulisan # Squid normally listens to port 3128. Ex:
# TAG: http_port
# Usage: port [options]
# hostname:port [options]
# 1.2.3.4:port [options]
#
…………………………..
#
# Squid normally listens to port 3128
http_port 8080

b. TAG: visible_hostname
Digunakan untuk menampilkan nama yang digunakan ketika terjadi pesan kesalahan. Tambahkan tulisan visible_hostname di bawah tulisan none, seperti di bawah ini.
# TAG: visible_hostname
# If you want to present a special hostname in error messages, etc,
# define this. Otherwise, the return value of gethostname()
# will be used. If you have multiple caches in a cluster and
# get errors about IP-forwarding you must set them to have individual
# names with this setting.
#
#Default:
# none
visible_hostname server

c. acl (access control list)
misalnya bwat acl untuk untuk jaringan local anda
ex : acl lan src 192.168.0.0/24
d. Tag: http_access
Menambahkan http_access allow localhost, dimaksudkan untuk membuat agar komputer server proxy dapat mengakses proxy yang dipasang pada dirinya. Tambahkan di bawah localnet.# TAG: http_access
# Allowing or Denying access based on defined access lists
#
# Accessi to the HTTP port:
# http_access allow|deny [!]aclname …
#
# NOTE on default values:
#
# If there are no “access” lines present, the default is to deny
# the request.
#
# If none of the “access” lines cause a match, the default is the
# opposite of the last line in the list. If the last line was
# deny, the default is allow. Conversely, if the last line
# is allow, the default will be deny. For these reasons, it is a
# good idea to have an “deny all” or “allow all” entry at the end
# of your access lists to avoid potential confusion.
#
#Default:
# http_access deny all
#
#Recommended minimum configuration:
#
…………………………………………..
# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost
http_access allow lan
e. TAG: dns_nameservers
Untuk mencari tau berapa DNS kita di windows, gunakan command ipconfig /all pada command prompt. Kemudian cari DNS servernya. Kemudian masukkan DNS server yang didapat dari command tadi dengan format dns_nameserver [primary] [secondary]# TAG: dns_nameservers
# Use this if you want to specify a list of DNS name servers
# (IP addresses) to use instead of those given in your
# /etc/resolv.conf file.
# On Windows platforms, if no value is specified here or in
# the /etc/resolv.conf file, the list of DNS name servers are
# taken from the Windows registry, both static and dynamic DHCP
# configurations are supported.
#
# Example: dns_nameservers 10.0.0.1 192.172.0.4
#
#Default:
# none
dns_nameservers 202.155.0.10 202.155.0.15
f. Tag: cache_mem
Digunakan untuk menentukan besarnya cache memory yang akan digunakan oleh squid untuk melakukan caching object. Sebaiknya nilainya 1/3 dari total keseluruhan RAM. Dan ukuran ini akan digunakan oleh squid sebagai batas maksimal penggunaan memory.# TAG: cache_mem (bytes)
#
……………………………………
# If circumstances require, this limit will be exceeded.
# Specifically, if your incoming request rate requires more than
# ‘cache_mem’ of memory to hold in-transit objects, Squid will
# exceed this limit to satisfy the new requests. When the load
# decreases, blocks will be freed until the high-water mark is
# reached. Thereafter, blocks will be used to store hot
# objects.
#
#Default:
# cache_mem 8 MB
cache_mem 64 MB
g. Tag: maximum_object_size_in_memory
Menentukan besar maksimal object yang akan di-caching pada memory. Object yang lebih besar dari nilainya tidak akan dicache oleh squid.# TAG: maximum_object_size_in_memory (bytes)
# Objects greater than this size will not be attempted to kept in
# the memory cache. This should be set high enough to keep objects
# accessed frequently in memory to improve performance whilst low
# enough to keep larger objects from hoarding cache_mem.
#
#Default:
# maximum_object_size_in_memory 8 KB
maximum_object_size_in_memory 1024 KB
h. Tag: maximum_object_size
Menentukan besarnya object yang akan disimpan di harddisk.# TAG: maximum_object_size (bytes)
# Objects larger than this size will NOT be saved on disk. The
# value is specified in kilobytes, and the default is 4MB. If
# you wish to get a high BYTES hit ratio, you should probably
# increase this (one 32 MB object hit counts for 3200 10KB
# hits). If you wish to increase speed more than your want to
# save bandwidth you should leave this low.
#
# NOTE: if using the LFUDA replacement policy you should increase
# this value to maximize the byte hit rate improvement of LFUDA!
# See replacement_policy below for a discussion of this policy.
#
#Default:
# maximum_object_size 4096 KB
maximum_object_size 4096 KB
i. Tag: minimum_object_size
Digunakan untuk menentukan besarnya file minimum yang akan disimpan di dalam harddisk.# TAG: minimum_object_size (bytes)
# Objects smaller than this size will NOT be saved on disk. The
# value is specified in kilobytes, and the default is 0 KB, which
# means there is no minimum.
#
#Default:
# minimum_object_size 0 KB
minimum_object_size 0 KB
j. Buka “Command Prompt”, kemudian masuk ke directory “squid” tadi melalui “Command Prompt”. Contohnya adalah dengan mengetik “cd C:\squid\sbin\”
k. Setelah masuk ke dalam direktori sbin, ketikkan perintah “squid -z”. Perintah ini digunakan untuk membuat direktori cache_dir.
l. Kemudian ketik “squid -d l -D“, setelah itu tekan ctrl+c.
m. Setelah itu mendaftarkan squid ke registry windows dengan jalan ketik “squid i”
n. Kemudian yang terakhir ketik “squid -O -D
o. Kamu bisa menjalankan squid dengan cara ketik services.msc di start menu -> run.

sumber : leonaras.wodpress.com