Blokir Situs dengan Mikrotik

Kemarin saya dapat tugas untuk melakukan blokir terhadap situs. Tapi blok situs tersebuh harus berdasarkan waktu. jadi hanya waktu-waktu tertentu saja untuk dilakukan pemblokiran.
Biasanya ini mungkin digunakan untuk memblokir pada jam-jam kerja. Setelah searching dengan bantuan mbah google akhirnya nemu juga artikelnya dan saya coba dan alhamdulilah berhasil. Untuk kasus kali ini akan dilakukan pemblokiran situs facebook karena situs jejaring yang satu ini sangat sering sekali diakses. berikut langkah-langkahnya :

1. Membuat firewall filter untuk memblokir content facebook yang menggunakan port http/80.

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol tcp dst port=80 content="facebook" action=drop comment="blokir Facebook"

2. membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat. ada 3 script yang digunakan yaitu untuk mengaktifkan firewall, mendisable firewall dan disable firewall di hari libur dan enable di di hari kerja
a. script untuk mengaktifkan firewall

/system script add name="fb-deny" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=no}

b. script untuk mendisable firewall

/system script add name="fb-allow" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=yes}

c. script untuk disable firewall di hari libur dan enable di hari kerja

/system script add name="fb-holiday" policy=write,read,policy,test,sniff source={:if ([/system scheduler get [/system scheduler find on-event="fb-deny"] disabled] = true) do [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=no] else [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=yes]}

3. Membuat schedule untuk menentukan kapan firewall diaktifkan atau di nonaktifkan. untuk schedulernya bisa seperti berikut :
a. Schedule untuk mengaktifkan firewall pada jam kerja (09.00) :

/system scheduler add name="fb-09:00" start-date=jan/01/1970 start-time=09:00:00 interval=1d on-event="fb-deny"

b. Schedule untuk disable pada jam istriahat (12:00)

/system scheduler add name="fb-12:00" start-date=jan/01/1970 start-time=12:00:00 interval=1d on-event="fb-allow"

c. Schedule untuk mengaktifkan pada jam kerja (13.00)

/system scheduler add name="fb-13:00" start-date=jan/01/1970 start-time=13:00:00 interval=1d on-event="fb-deny"

d. schedule untuk disable pada jam pulang kantor ( > 18:00)

/system scheduler add name="fb-18:00" start-date=jan/01/1970 start-time=18:00:00 interval=1d on-event="fb-allow"

e. schedule untuk disable firewall di hari libur (Sabtu dan Minggu)

/system scheduler add name="fb-sabtu-minggu" start-date=aug/01/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler adalah Hari Sabtu. Dan parameter “interval” diberi nilai 7d.

f. schedule untuk mengaktifkan kembali di hari kerja (Senin)

/system scheduler add name="fb-senin" start-date=aug/03/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler adalah Hari Sabtu. Dan parameter “interval” diberi nilai 7d.

sumber : http://lulukn.abatasa.com

berikut saya sertakan konfigurasi dengan menggunakan winbox : untuk source bisa didownload di alamat dibawah ini

BLOK SITUS DENGAN WINBOX MIKROTIK

About 3wahyua

Islam is my way

Posted on May 16, 2011, in mikrotik. Bookmark the permalink. 2 Comments.

  1. rule diatas apa gak salah bro, fb-deny dua duanya tuh kapan allow nya😦

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: